[Bioclusters] Wrong system and load values from GE on MacOS X

Beltrami, Riccardo bioclusters@bioinformatics.org
Wed, 06 Aug 2003 23:25:26 +0200

Dear all,

I'm trying to add few MacOS X execution nodes in our experimental Grid 
Engine cluster.

The GE port I'm using is the Van Etten's 5.3p2 version available as a 
package on the BioTeam web site.

It's working ok however when I run qhost as user sgeadmin on an 
administration host I get:

stark                darwin         1     -      0.0        -      0.0        -

where stark is my MacOS X execution host.

The problem is that stark is a dual processor PPC G4 1.25GHz with 1.5GB of 
RAM so the NPROC, MEMTOT etc. values are wrong reported.

In fact, if I run the command loadcheck found in $SGE_ROOT/utilbin/darwin 
directory as user root this is what I get:

# ./loadcheck
arch            darwin
num_proc        1
load_short      0.00
load_medium     0.00
load_long       0.00
mem_free        0.000000M
swap_free       0.000000M
virtual_free    0.000000M
mem_total       0.000000M
swap_total      0.000000M
virtual_total   0.000000M
mem_used        0.000000M
swap_used       0.000000M
virtual_used    0.000000M
cpu             0.0%

Those values are clearly wrong, and if I run the same command on other 
execution host (for example Solaris/Sparc machine) I get correct values.

Stark runs MacOS X 10.2.6 with all the latest patches available from Apple.

Does anybody know how to fix/solve this problem?

Tia, Riccardo.

                         / \
  | Riccardo Beltrami                               |-.
  |                                                 | |
  | Bioinformatics                                  | |
  |                                                 | |
  | riccardo_beltrami@chiron.it                     | |
  |                                                 | |
  `-------------------------------------------------' |