[Bioclusters] blast server on OpenMosix cluster

Hong Zhang bioclusters@bioinformatics.org
Thu, 11 Dec 2003 10:49:02 -0500 (EST)

I think I successfully installed OpenMosix in every nodes. And by 
test(the small program recommended by lots of guide), I am sure the 
cluster is able to migrate jobs properly. 

But I have trouble make blast command line execute in every node.

And don't you think openmosix is suitable for blast cluster? You suggested 

 On Thu, 11 Dec 2003, Farul Mohd. Ghazali wrote:

> On Wed, 10 Dec 2003 hong.zhang@research.dfci.harvard.edu wrote:
> > I am working on set up a blast server on Debian/OpenMosix cluster with 4
> > nodes. Actually it is totally new to me. So is there anyone can give me
> > some advice? Thanks.
> I've used OpenMosix in the form of ClusterKnoppix some months back to test
> it out. The setup was very easy, boot off the CD, configure some settings
> and the rest of the nodes boot off the network. Applications are
> automatically load balanced across nodes.
> While configuration and actual use was very easy, performance wasn't too
> great. I think the main reason was that OpenMosix dynamically migrates
> applications to the different nodes to automatically load balance the
> system thus the overhead of migration for long running jobs suddenly
> became apparent.
> To be honest, we didn't try to optimize it much and went to implement our
> blast cluster with SGE and hopefully soon mpiblast.
> _______________________________________________
> Bioclusters maillist  -  Bioclusters@bioinformatics.org
> https://bioinformatics.org/mailman/listinfo/bioclusters

Hong Zhang, MIS
Bioinformatics Analyst
Dana Farber Cancer Institute
Harvard Medical School
44 Binney St, D1510A
Boston MA 02115
Email: hong.zhang@research.dfci.harvard.edu
Phone: 617-632-3824
Fax: 617-632-3351